Gen 1 Key fob button repair!

Post Reply
User avatar
petrolhead_rob
Very regular contributor
Posts: 1548
Joined: Wed Oct 27, 2010 12:34 am
Coupe: Gen1 (1996 -1999)
Engine: 2.0
Location: Bristol
Has thanked: 0
Been thanked: 0

Gen 1 Key fob button repair!

#1

Post by petrolhead_rob » Tue Sep 18, 2012 9:42 pm

For some reason (only know to the fob itself!) this happened to me the other day. Found it is really simple to fix, thought I would post it here to give others the confidence to do it and save money rather than running to the dealer! ;)

When I tried to lock the car with the fob - it decided it would not work. After trying a few a words of encouragement and pressing that bit harder on the button (we all do this when the batteries are going on the TV remote), I gave up and locked it with the key. Thinking it is the battery that had gone. :think:

I then thought I would try and unlock it with the fob, this worked. Ah ha! not the battery - must be the button! I then noticed when I pressed the lock button the little LED on the fob was not lighting up.

So decided to open it up and see what the problem is - got nothing to lose as it is not working anyway!

You will need

1 Precision Phillips head screw driver
1 Precision flat head screw driver
Pair of tweezers
Super glue or equivalent
Optional - soldering iron and solder.
Time - +5mins (dependent on drying time)


First take the fob off your key ring, don't try to do this when it is still on the key ring!
SAM_0470.JPG
Flip it over and undo the small screw using the phillip head screwdriver. Tip - I did this all on a white piece of paper so I didn't lose the little screw ;)
SAM_0471.JPG
Now using the flat head screwdriver gentle prise the two sides of the fob apart at one end and then repeat on the opposite end, it will make a reassuring "pop" noise, take off the top side.
SAM_0472.JPG
Here is how it should look - these are the buttons on the circuit board highlighted by the red rings. left one is "unlock", right one is "lock".
SAM_0475a.jpg
Here is mine! As you can see the "lock" button had decided it wanted be somewhere else!
SAM_0476.JPG
Test!!!! - I placed the button back into postion, held it in place and pressed the red circle, the LED lit up!

I used a tiny amount of glue on the bottom of the button to secure it into position - lining up the connection points on the circuit board as per the pic, make sure they line up on the other side too!
SAM_0481.JPG
Test again!!! To make sure LED comes on when pressing the button - leave to set and go make a cup of tea!
SAM_0485.JPG
You may need to use a soldering iron to resolder the joints if they have come away from the circuit board too. This was not the case with mine, connections were fine when the button was back in place.


Once the glue is set put the fob back together by pusing the two sides together, put the screw back in and thats it! :icon-biggrin:


Click here to view my car.

Post Reply